封面

ATP2410系列录音服务器

ATP2410-8

ATP2410-16

ATP2410-24

模拟电话录音服务器

用户手册

Version 4.0.0.0


目 录

目 录... i

版本修订记录... iii

第1章 概 述... 1

1.1 应用场景图... 1

1.2 功能列表... 1

1.3 产品外观说明... 3

1.4 按键操作说明... 3

第2章 安 装... 5

2.1 包装内容... 5

2.2 安装步骤... 5

2.3 快速运行... 5

第3章 使用说明... 7

3.1 登录系统... 7

3.2 通道状态... 8

3.3 录音选项... 10

3.3.1 录音查询... 11

3.3.2 录音参数... 13

3.3.3 DVD刻录... 14

3.4 系统设置... 15

3.4.1 系统配置... 16

3.4.2 存储配置... 17

3.4.3 号码设置... 19

3.4.4 IP配置... 22

3.4.5 调试日志... 22

3.4.6 告警设置... 23

3.4.7 时间设置... 25

3.4.8 SNMP设置... 26

3.4.9 远程更新... 26

3.4.10 WEB 设定... 27

3.5 用户管理... 27

3.6 信息管理... 30

3.6.1 座席管理... 31

3.6.2 客户管理... 32

3.7 统计报表... 35

3.8 日志查询... 36

3.9 更改口令... 37

3.10 数据库管理... 37

3.10.1 数据库设置... 38

3.10.2 数据库还原... 39

3.11 集中管理... 39

3.11.1 管理主页... 39

3.11.2 主从设置... 42

3.12 重启复位... 42

3.13 FTP功能... 43

3.14 即时监听... 44

3.14.1 安装RemoteListener 44

3.14.2 选择监听通道... 45

3.14.3 监听工具的使用... 45

3.15 告警信息说明... 45

3.15.1 SD卡异常告警... 45

3.15.2 磁盘异常告警... 46

3.15.3 长时间无录音告警... 46

3.15.4 线路异常告警... 46

3.15.5 录音服务异常告警... 46

3.15.6 集中管理设备断网告警... 46

3.15.7 数据库损坏告警... 47

附录A 主要技术/性能参数... 48

附录B 常见问题... 49

附录C 技术/销售支持... 50


版本修订记录

版本号 | 发布日期 | 修订内容
Version 3.1.0.0 | 2016.05 | 新创建此文档。
Version 4.0.0.0 | 2016.09 | 修订此文档。


第1章 概 述

欢迎使用ATP2410系列录音服务器（以下简称录音服务器）。录音服务器可独立进行全天候录音，通话记录和录音文件存储在内置硬盘，每条通话记录都包括通话起止时间、来去电号码、通话时长、座席、通道号等详细信息。录音服务器支持网络管理，用户通过WEB即可进行更改配置、查看实时状态、查询录音、备份文件、录音刻录等操作。机器面板自带LED显示屏及配置按钮，没有计算机时也可以更改IP地址、查看通道状态和硬盘状态；机器面板带LED指示灯，可以指示通道状态、设备状态等。ATP2410录音服务器提供DLL和webservice接口，提供配置和查询功能。ATP2410系列有ATP2410-8、ATP2410-16和ATP2410-24共3个型号，分别包含8、16和24个录音通道。


1.1 应用场景图

图 1‑1录音服务器应用场景图


1.2 功能列表

功能 | 详细介绍
录音查询功能 | 支持单条件查询或多条件组合查询。
 | 录音查询字段包括：通道号、主叫号码、被叫号码、录音时间段、录音时长、呼叫方向、出局类型（长途、市话）等。
 | 录音查询结果可导出成Excel文件。
 | 支持对录音条目进行备注。
 | 支持对选定录音文件进行播放、下载或删除操作。
通道监听功能 | 具有监听权限的系统用户可对正在录音的通话进行实时监听。
统计报表功能 | 可按主叫号码、被叫号码、录音时间段、呼叫方向、出局类型、录音长度等，进行单条件统计或多条件组合统计。
 | 能够详细统计出总通话次数、总通话时长、平均时长、长话次数、长话时长、市话次数、市话时长、呼出次数、呼出时长、呼入次数、呼入时长、未接来电等相关录音文件信息。
 | 报表可导出成Excel文件。
系统日志功能 | 系统具备日志生成功能，可记录客户端及服务器端各用户使用系统的详细情况及操作时间。
录音参数设置 | 提供文件保存格式、压缩格式、静音阀值、告警方式等多项设置。
 | 压控、声控、码控、一直录音、压控（只录通话内容）五种录音类型可供选择（支持每个通道单独设置录音方式）。
 | 支持设置录音时间：可以设置3个录音时间段，时间段之外的通话将不予录音。
录音磁盘管理 | 自动扫描所有磁盘，计算容量使用情况。
 | 一个设备存满时自动保存至下一个设备。
 | 磁盘全满时将产生报警或根据设置删除部分数据。
录音备份管理 | 可设置每天自动备份当天的录音数据，一旦设定，系统将把录音文件备份到指定的磁盘。
 | 可设置备份时长，当超过设置时间自动删除超时的备份文件。
 | 可实现磁盘空间不足设定下限时自动删除最早的备份文件。
 | 可将录音文件上传到指定的外部FTP上进行备份。
WEB用户管理 | 可以增加、删除、修改web用户信息，系统用户数量不受限制。
 | 可为不同WEB用户分别定制权限。
通道参数设置 | 可以设置对应通道的电话号码、座席工号。
 | 所有通道可独立设置是否录音，有全部都录、只录来话、只录去话、全部都不录等四种方式可供选择。
 | 所有通道参数相同时，亦可将一次设置的结果保存应用到所有通道。
 | 可以设置指定通道断线时发出告警。
号码过滤功能 | 可以设置某号码或以某串前缀开头的号码是否需要录音。
 | 可以设置识别哪些号码是长途区号。
 | 支持批量增加号码信息。
 | 可以设置某号码或以某串前缀开头的号码来电时弹出来电信息。
座席信息管理 | 可以增加、修改座席人员信息。
 | 支持将座席信息导入到Excel中。
 | 支持从Excel中批量导入座席信息。
客户信息管理 | 可以增加、修改客户信息。
 | 支持将客户信息导入到Excel文件中。
 | 支持从Excel文件中批量导入客户信息。
告警功能 | 提供声音告警、WEB页面告警、邮件告警。
 | SD卡异常告警、磁盘异常告警、长时间无录音告警、线路异常告警、录音服务异常告警、集中管理设备断网告警、数据库损坏告警
 | 软件异常时自动重启恢复正常工作。
重启复位功能 | 支持录音服务的重启复位功能。
板卡驱动配置 | 支持通过WEB页面的形式实现板卡驱动的查看和修改。
录音服务器信息远程修改功能 | 支持录音服务器IP地址的远程修改。
 | 支持录音服务器日期和时间的远程修改。
集中管理功能 | 支持主设备（PC或者ATP2410录音设备）通过网络集中管理从设备。
数据库管理功能 | 可设置自动备份数据库，一旦设定，系统将定期备份数据库表单。
 | 可通过设置开放数据库的外部接口。
 | 支持将数据库还原到之前备份的时间点。
高阻复接无源监听 | 适用于各种环境下、密度高低不同的场合，可广泛地应用于电话录音系统、呼叫中心监控系统等。
信号音检测 | 可同时支持DTMF和FSK检测。
 | 可配置信号音检测器，检测任何类型的信号音。
电压检测 | 可自动检测线路电压变化并在WEB界面上显示。
录音刻录 | 选择一个录音文件进行刻录。
webservice接口 | 配置webservice接口，默认值为80。


1.3 产品外观说明

图 1‑2前面板示意图

图 1‑3后面板示意图


1.4 按键操作说明

录音服务器支持通过按键和显示屏查看工作状态及配置IP地址。具体操作如下：

图 1‑4 按键操作说明流程图

说明：

1. 流程图中图片为显示屏显示的实际界面，箭头及对应文字代表按键操作及方向。各按键在录音服务器面板上的位置见1.3产品外观说明。

2. 主界面 [image] 中的“Working”字样，在录音服务器启动过程中显示为“Booting”。

3. 通道状态界面 [image] 中，CH代表通道号，ST代表状态。各状态的显示及含义分别为：ID（空闲）、OF（断线）、RI（振铃）、PI（摘机）。

4. 在IP设置界面 [image] 中，可以进行IP地址配置。具体方法如下：显示屏上闪烁的字段为当前设置的字段，此时“+/-”按键用于设置当前字段值，“OK”按键用于跳到下一个字段。全部字段配置完成后，使用“ESC”按键保存设置并回到IP设置的主界面。


第2章 安 装


2.1 包装内容

l ATP2410录音服务器1台，内含2.5英寸500G硬盘一个

l 脚板2个、脚垫4个、脚板螺丝8颗

l 使用说明书1份

l DC19V电源1个


2.2 安装步骤

第一步：接入19V电源线。

第二步：接入网线。

第三步：将电话线的一端并接在交换机与电话机之间连线的任一位置上，另一端连到录音服务器的RJ11接口上。

文本框: Ch11 b 文本框: Ch11 a 文本框: Ch11 a 文本框: Ch11 b

图 2‑1 RJ11接线示意图

第四步：通过显示屏检查第三步中连接的通道，通道状态显示为ID（空闲）表示连接正常，否则该通道不可用，需要重新检查连线。

第五步：通过录音服务器面板上的配置按钮修改录音服务器的IP地址，具体方法见1.4按键操作说明。（注：IP地址也可以通过WEB界面修改，具体方法及默认值见3.4.4 IP配置。）

第六步：通过浏览器输入第五步中设置的IP地址，进入管理软件。具体登录方法见3.1登录系统。

第七步：通过WEB界面检查硬盘是否格式化，未格式化的硬盘需要首先进行格式化操作，才能够正常使用，具体方法见3.4.2存储配置。


2.3 快速运行

完成以上步骤，录音服务器即可正常运行，主要录音配置参数的默认值如下：

l 录音类型：压控

l 压缩格式：G711-A率

l 文件保存格式：wav

l 录音时间段：24小时录音

l 录音方向：来去话都录音

如果需要修改录音参数的配置，请参考3.3.2 录音参数。

注意：

1. 建议用户在初次登录后，尽快修改初始密码。用户密码修改方法见3.9 更改口令。

2. 为完善录音信息，用户需添加相关座席及客户信息，信息添加及管理方法见3.6信息管理。

3. 录音服务器的详细配置与具体操作将在第3章 使用说明中介绍。

特别注意：

l 当听到告警音时，应参照用户手册分析告警类型，并及时进行相应处理，否则可能会出现性能下降或发生意外错误的情况。

l 按照电信设备使用的常规要求，录音服务器的外壳必须可靠接地，机器上有接地螺柱提供接地功能。如果不接地，或接地不可靠，都可能引起录音服务器工作不稳定且抗雷击能力降低等情况。


第3章 使用说明


3.1 登录系统

在浏览器地址栏输入管理软件的IP地址，进入登录界面，如图 3‑1所示：

图 3‑1登录界面

管理软件初始只设一个超级管理员用户，用户名为admin，初始密码为admin。

用户登录成功后，界面显示如下：

图 3‑2开放所有功能的主界面

对于拥有所有权限的用户，上图所示菜单栏中的所有功能全部开放；对于其他用户，系统会根据不同的功能权限取消某些菜单的显示。

用户可以对密码进行重新设置，具有系统设置权限的用户还可以修改管理软件的IP地址使之与平时使用的PC在同一个网段内，以免每次访问时都需要修改访问PC的IP地址，具体的IP地址修改方式见 3.4.4 IP配置 。


3.2 通道状态

图 3‑3 通道状态界面

通道状态界面见图 3‑3，以上列表显示了录音通道的工作状态，支持查询正在录音通道的客户信息、座席信息，以及对该通道的通话进行监听。以上列表中各查询项的说明如下：

查询项 | 说明
监听 | 当监听列出现 [image] 图标时，说明该通道正在进行录音，客户只要点击该图标就可以听到该通道上的通话语音，具体设置参见3.14即时监听。
通道 | 通道在录音服务器上的逻辑序号。
电压 | 对应通道上的线路电压。
状态 | 通道状态，通道的工作状态有四种，分别为：空闲、摘机、振铃、断线，如图 3‑3所示。
远端号码 | 呼入监控端或监控端呼叫的外部电话号码，若系统中有该号码对应的客户信息，则点击该号码会弹出图 3‑4所示的客户信息界面。客户信息可在3.6.2客户管理中添加及修改。
DTMF | 显示与录音线路连接的话机和远端话机上所按的DTMF码。
座席工号 | 通道对应的座席工号，若系统中有该工号对应的座席信息，则点击该号码可以查询对应的座席信息。座席信息界面如图 3‑5所示。座席信息可在3.6.1座席管理中添加及修改。座席工号与号码、备注 一样，都可以通过修改 功能进行修改。
姓名 | 通道对应的座席姓名。
号码 | 录音通道监控的话机号码，可以通过修改 功能进行修改。
呼叫方向 | 此次呼叫的方向，以监控端为参照，如果监控端作为主叫呼出，则显示呼出图标，如果监控端作为被叫呼入，则显示呼入图标。
录音起始时间 | 此次录音开始的时间。注意：录音文件是否需要保存的判断条件有很多，所以此界面上显示的录音，不一定会保存为录音文件，录音数据以录音查询结果为准，请参见3.3.1录音查询。
录音持续时间 | 此次录音持续的时间，单位为秒。
备注 | 通道的备注信息，可作为对不同功能通道的标记，并可通过修改 功能进行修改。

点击远端号码 时，若系统中有该号码对应的客户信息，弹出的客户信息界面如下图所示：

图 3‑4 弹出的客户信息界面

座席员配置好后可以使录音机融入到公司的局域网中，若“接录音，如图点击座席工号 时，若系统中有该座席工号对应的座席信息，弹出的座席信息界面如下图所示：

图 3‑5 弹出的座席信息界面

点击图 3‑3中的修改，可以修改通道参数。修改界面如图 3‑6所示。

图 3‑6 通道信息修改界面

修改界面中配置项号码、座席工号 和备注 的内容与通道状态界面 的对应查询项相同，其他配置项录音方向、断线是否告警、应用于其它通道，说明如下：

设置项

说明

录音方向

设置通道需要对哪一种通话方式进行录音，目前提供四个可选项：

可选项 | 说明
只录来话 | 以监控端作为参照，只对呼入的通话进行录音
只录去话 | 以监控端作为参照，只对呼出的通话进行录音
全部都录 | 以监控端作为参照，呼入和呼出的通话都会被录音
全部都不录 | 监控端无论作为呼入或呼出端，通话都不会被录音

注意：该设置项只有在录音模式不是一直录音（3.3.2 录音参数）的情况下有效，如果录音模式为一直录音，则该设置项无效。

断线是否告警

设置是否在通道断线时发出告警。

应用于其它通道

将此次修改的录音方向、断线是否告警 应用到其它通道。

配置完成后，点击保存 将以上信息存入数据库。需要重启才能使设置生效，可以通过 3.12重启复位菜单直接在WEB页面上重启录音服务。点击关闭 可直接取消设置。


3.3 录音选项

录音选项包括录音查询、录音参数和 DVD刻录三部分。录音查询用于查询录音记录。本产品提供了丰富的录音查询组合条件，用户可以通过组合条件快速地定位到需要的录音记录。录音参数用于管理软件整体的录音配置，用户可以根据需求进行设置。DVD刻录用于将需要的录音文件刻录到DVD光盘。


3.3.1 录音查询

图 3‑7 录音查询条件界面

录音查询界面见图 3‑7，录音查询条件可以是多个条件组合的形式，各配置项的意义说明如下：

配置项 | 说明
开始日期、开始时间、结束日期、结束时间 | 录音开始及结束的具体日期及时间段，比如上图中显示的查询时间段为2016-05-19 00:00:00到2016-05-19 23:59:59。结束日期及时间必须不早于开始日期及时间。
呼叫方向 | 以监控端作为参照，按照全部、呼入、呼出 三种方式进行过滤，默认为全部。
录音长度 | 一次通话的录音时间长度，可以按照不限、大于、小于 三种方式进行过滤，不限 是指不对录音长度做过滤，选择大于 或小于 时需要在后面的编辑框中输入参数（单位为秒），按照设定方式对录音长度进行过滤。只有符合条件的录音才会被显示出来，默认为不限。
座席工号、座席姓名、座席部门 | 座席信息（详见3.6.1座席管理）。若座席与通道绑定，那么该通道在产生录音文件时会将录音信息与座席信息一起保存到录音记录中，用户可以通过这三个字段对该录音信息进行查找。这三个字段都可以为空，表示不针对这三个字段进行过滤。建议：查询时，座席工号和座席姓名不要同时输入。
客户号码、客户姓名 | 客户信息（详见3.6.2客户管理）。当远端号码与客户信息中的电话号码匹配时，通话产生的录音文件会将该客户信息一起保存到录音记录中，用户可以通过这两个字段对该录音进行查找。两个字段都可以为空，表示不针对这两个字段进行过滤。建议：查询时，客户号码和客户姓名不要同时输入。
主叫号码、被叫号码 | 按照主叫号码、被叫号码进行过滤，只要输入需要查询的号码即可。
是否听过 | 表示录音文件是否已经播放过，提供不限、是、否 三种选项，默认为不限。
通道选择 | 指定要查询的通道范围，两个组合框从左到右分别表示需要查询的起始通道和结束通道，起始通道必须不大于结束通道。当起始通道与结束通道的值相等时表示只对这一个通道进行查询。默认为所有通道。
出局类型 | 对市话和长途进行过滤，提供全部、市话、长途三个选项，选择全部 时不对出局类型进行过滤。
未接来电 | 指定需要查询的录音文件是否是未接来电，默认值为不限。
DTMF | 按照录音记录里的DTMF码进行过滤。
查询范围 | 指定查询录音数据的范围，提供最新10万条记录、全部记录两个选项，全部录音数据比较耗时，默认为最新10万条记录。
排序选择 | 规定查询结果的排序方式，可按记录时间、录音长度、座席工号 这三个字段的升序 或降序 进行排序，默认为记录时间 的升序。
备注 | 按照录音记录里的备注信息进行过滤。

录音查询条件配置完成后，点击查询 即可看到查询结果，查询结果如图 3‑8所示。点击重置 可恢复当前配置。

图 3‑8 录音查询结果

录音查询结果显示了各条录音记录对应的通道、呼叫方向、是否是未接来电、主叫号码、DTMF、被叫号码、记录时间（录音开始的时间）、录音长度、座席工号、姓名、客户号码、备注标记 和添加客户信息。在查询结果界面用户可进行以下操作：

操作项 | 说明
导出查询结果 | 将查询的结果导出到Excel表格中，由于Excel 2003最大只支持65535行，所以目前最多只能导出65535条查询结果，超过则会出现提示。
播放 | 播放录音记录对应的录音文件，对应的播放界面如图 3‑9所示。播放图标呈蓝色表示录音文件未被播放过，橙色表示录音文件被播放过，灰色表示录音文件已删除，无法播放。
下载 | 将录音记录对应的录音文件下载到本地。下载图标呈灰色表示该录音文件已删除，无法下载。录音文件的命名规则说明见3.13 FTP功能。
点击座席工号 链接 | 显示相应的座席信息。
点击客户号码 链接 | 显示相应的客户信息。
点击备注标记 链接 | 修改备注信息，并可将录音标记为重要和保留。
添加客户信息 | 添加该录音的客户号码到客户信息。图标绿色，点击进行添加；图标灰色表示没有号码或者该号码已经添加。

播放录音文件界面：

图 3‑9 录音文件播放界面

注：由于一些浏览器不能很好地支持播放插件，在当前浏览器无法播放时，可以采取切换播放器的方式进行播放。

如果需要删除录音信息，可以在图 3‑8界面中选择对应号码前的复选框，然后点击删除所选。删除后的记录在选择 栏目中的复选框将变灰，且无法对其执行播放 和下载 操作。全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录；反选 指取消选中当前页面已选中的记录，并选中原先未选中的记录。


3.3.2 录音参数

图 3‑10 录音参数配置界面

录音参数配置见图 3‑10，用户可以根据实际需求进行配置。每个配置项的具体说明如下：

配置项

说明

通道选择

选择当前配置的通道。

录音类型

录音启动控制方式，分为压控、声控、码控、一直录音和压控（只录通话内容）五种方式，具体说明如下：

录音类型 | 说明
压控 | 检测到摘机即开始录音
声控 | 检测到有效的信号音即开始录音
码控 | 检测到有效的DTMF组合即开始录音
一直录音 | 录音服务启动后即开始并始终保持录音
压控（只录通话内容） | 需要开通极性反转功能，在对方摘机后开始录音，录音内容只包含通话内容，没有拨号音。

注意：“一直录音”功能生效后，管理软件默认每 50M 录音数据生成一个录音文件，并切换至一个新文件进行录音。录音文件生成前，该录音记录在录音查询界面以及FTP的Record文件夹下都无法看到，但用户可以在FTP的temp目录下找到该录音的临时录音文件。

码控编码

该设置项只有在录音类型 为码控 时才有效。当系统检测到码控编码 中的DTMF组合被按顺序按下时即开始录音。

最短录音时间

只有当录音时间超过该设定值时才会被保存为录音文件，取值范围为1~60秒。

压缩格式

生成的录音文件的压缩格式，目前支持G.711μ、G.711、ADPCM和G729A。

文件保存格式

生成的录音文件的保存格式，目前仅支持wav和vox，默认为wav。其中vox文件格式没有文件头，只保存录音数据，不支持WEB播放。因此，如果需要使用WEB播放的功能，建议选择wav文件格式。

拨号按键最大间隔

用于判断DTMF按键时哪些是拨号的按键，哪些是拨号之后的按键，主要用在被监控端做主叫时。摘机拨号时，只要按键发生在最大间隔时长内且尚未检测到回铃音，则这几个DTMF都被认为是远端号码，如果按键间隔超过最大间隔时长或发生在检测到回铃音之后，则超时或回铃音之前部分的号码被认为是远端号码。拨号按键最大间隔单位为秒。

码控按键最大间隔

该配置项只有在录音类型 为码控 时有效，用于确定组合键的有效时间间隔，时间单位为秒。举例：若该配置项值为5，码控编码 为“*1”，当检测到“*”后，如果超过5秒后才检测到“1”，则此组合键无效，不会录音；只有在5秒之内检测到完整的码控编码才会被认为有效并开始录音。

选择录音时段

设置录音服务器需要对哪些时间段的通话进行录音，可以选择24小时录音或在设定的时间段内录音。若选择对所有时间进行录音，则直接勾选“24小时录音”选项框即可；若选择在设定的时间段内录音，需要勾选时间段复选框并填写对应的时间段，管理软件最多支持三个时间段的设定。

配置完成后，点击保存 将以上设置存入数据库。需要重启才能使设置有效，可以通过 3.12重启复位菜单直接在WEB页面上重启录音服务。点击重置 可恢复当前配置。


3.3.3 DVD刻录

图 3‑11 DVD刻录界面

DVD刻录界面见图 3‑11，用户可以根据实际需求将需要的录音文件刻录到光盘。每个配置项的具体说明如下：

配置项 | 说明
日期、月份 | 设置DVD刻录的数据范围，可以根据具体时间或者月份进行选择。
开始日期、结束日期 | 设置需要刻录的录音数据开始和结束时间。
月份、年份 | 设置需要刻录的录音数据的年份和月份。
媒体类型 | 设置光盘的类型，包括DVD-R和DVD-RW两个选项。

点击连接 DVD刻录器 检查是否正确连接DVD刻录器，点击 DVD是否可用 检查DVD是否可用，点击计算数据 DVD大小 检查连接的DVD剩余空间是否足够写入录音数据。如果以上检查都没有问题，点击写入 DVD，将录音数据刻录到DVD上。


3.4 系统设置

主界面左侧菜单栏的系统设置下有：“系统配置”、“存储配置”、“号码设置”、“IP配置”、“调试日志”、“告警设置”、“时间设置”、“SNMP设置”、“远程更新”、“WEB设定”等子栏目，如下图所示：

图 3‑12 系统设置栏


3.4.1 系统配置

图 3‑13 系统配置

见图 3‑13，系统配置是指录音服务器硬件的配置。每个配置项的具体说明如下：

配置项 | 说明
语音卡序列号 | ATP语音卡序列号（只读）。
使用通道总数 | 系统中使用的通道总数（只读）。
忽略线路电压 | 设置是否忽略线路上的电压检测结果。 取值范围：0：否（缺省值）；1：是。
摘挂机判定电压 | 设置ATP语音板卡的录音通道的摘/挂机判定电压，单位为V，缺省值为16。
输入增益 | 设置模拟录音通道上输入信号的增益。 取值范围：0：正常增益（0DB）；1：高增益（20DB），目前仅支持配置为0。
缺省录音音量 | 设置录音音量的增益。 取值范围：-7~6，小于0表示音量衰减，大于0表示音量提升，-7表示关闭，缺省值为0。本配置项的值乘以3即为音量的分贝值。
bargein灵敏度 | 设置Barge In检测器的灵敏度。 取值范围：0~31，取值越大灵敏度越高，缺省值为6。
bargein判定时间 | 设置Barge In的最小保持时间。 取值范围：³16，且必须是16ms的整数倍，单位为毫秒，缺省值为32。
DTMF接收灵敏度 | 设置DTMF信号的高电平、低电平的最小保持时间n。 n包含8个比特（记为Bit7…Bit0），各比特含义如下： Bit3~Bit0：高电平最小保持时间，取值范围为1~6，单位为16毫秒，缺省值为3； Bit7~Bit4：低电平最小保持时间，取值范围为0~6，单位为16毫秒，缺省值为0。 注意：如果Bit7~Bit4取值为0，那么低电平最小保持时间由高电平最小保持时间决定。如果高电平最小保持时间小于3，那么低电平最小保持时间取值为1；否则，低电平最小保持时间取值为2。 n采用16进制表示。例如：n=0x43，表示高电平、低电平的最小保持时间分别为48、64毫秒；n=0x03，表示高电平、低电平的最小保持时间分别为48、32毫秒。
DTMF判定为有声 | 设置是否将来话信号中的DTMF信号视为语音信号。 取值范围：0：否；1：是（缺省值）。
静默最小保持时间 | 设置静默的最小保持时间。 取值范围：³16，且必须为16毫秒的整数倍，单位为毫秒，缺省值为5000。
噪音判定门限 | 设置Barge In检测器的噪声判定门限，缺省值为100,000。
API函数和事件信息 | 设置是否将应用程序调用API函数的调试信息输出。
日志保存路径 | 设置日志存放的路径，设置的路径必须存在。
自动开启AGC功能 | 启用AGC功能，录音服务器会自动调节输入信号的幅度，对小信号进行提升，对大信号进行衰减。默认为否。
系统语言 | 设置录音服务器的系统语言，包含简体中文、繁体中文和英文三种，默认为简体中文。

配置完成后，点击保存 将以上设置存入数据库。需要重启才能使设置生效，可以通过 3.12重启复位菜单直接在WEB页面上重启录音服务。点击重置 恢复当前配置。


3.4.2 存储配置

录音服务器中没有插入硬盘时，存储配置界面如图 3‑14所示：

图 3‑14 暂无可用磁盘

录音服务器插入的硬盘不可用或未进行格式化，存储配置界面如图 3‑15所示：

图 3‑15 磁盘不可用

点击格式化磁盘 按钮。格式化磁盘需要输入管理员密码，见图 3‑16。

图 3‑16 输入管理员密码

输入正确的管理员密码并点击确定 后，管理软件将弹出对话框询问用户是否保留当前硬盘的配置信息，见图 3‑17。

图 3‑17 是否保留当前信息

点击确定 或取消 后，管理软件将弹出对话框要求用户再次确认是否需要格式化，见图 3‑18。

图 3‑18 确认格式化

点击取消 不对磁盘进行格式化，点击确定 ，磁盘开始格式化，见图 3‑19。格式化完成后，该界面会自动关闭，管理软件跳转至存储配置界面，见图 3‑20。

图 3‑19 磁盘格式化

图 3‑20存储配置界面

存储配置界面见图 3‑20，以上列表显示了管理软件所有可存储磁盘的信息，包括磁盘名称、磁盘位置、磁盘类型、磁盘文件格式、磁盘的总容量、已用容量和剩余容量等。列表右上方的格式化磁盘 按钮用于硬盘格式化；拔出磁盘 按钮用于在热插拔硬盘时防止录音数据的损坏或丢失。

注意：点击格式化硬盘 或拔出硬盘 按钮前，需要检查FTP功能和日志输出功能。如果正在使用FTP功能，必须先关闭。如果开启了驱动日志输出功能，必须将 3.4.1系统配置 中的API函数和事件信息 修改为不输出API和事件信息。

对于每个磁盘，用户可以进行如下设置：

配置项 | 说明
每个磁盘保留的大小 | 磁盘剩余空间小于该设定值时即认为磁盘已满，磁盘满会产生相应的告警信息（3.15.2磁盘异常告警），单位为MB，默认值为800。
自动删除的字节数 | 当录音服务检测到磁盘空间已满时，自动删除一部分数据，单位为MB，默认值为1024。
是否自动备份 | 设置管理软件是否对录音数据进行自动备份，以防止数据丢失。选择“是”后，备份文件超过多久自动删除 这个功能有效，否则无效。
备份路径 | 管理软件自动备份录音数据的路径（只读）。
备份文件超过多久自动删除 | 设置备份文件在磁盘中保存的期限，超时后该文件被自动删除，单位为秒，默认为36000秒。

在图 3‑20存储配置界面中，用户也可以设置将录音文件同步上传到指定的FTP，保证录音文件备份的可靠性。录音文件自动上传FTP功能相关配置项具体说明如下：

配置项 | 说明
录音文件自动上传FTP | 设置是否将录音文件自动上传到指定的FTP。
测试连接 | 向指定的FTP发送测试文件，确认录音文件能够上传到指定的FTP路径。
FTP地址和端口 | 指定FTP的地址及端口号。此配置项填写的格式为：FTP地址:端口号（FTP地址与端口号之间用英文冒号隔开）。
存储路径 | 设置录音文件在指定FTP上的存储位置。存储路径必须是FTP上已经存在的路径。
用户名、密码 | 具备该指定FTP的访问及文件上传权限的FTP用户名和密码。

配置完成后，点击保存 将以上设置存入数据库。需要重启才能使设置生效，可以通过 3.12重启复位菜单直接在WEB页面上重启录音服务。点击重置 恢复当前配置。


3.4.3 号码设置

图 3‑21 号码设置界面

见图 3‑21，以上列表显示了系统对不同来电号码进行的相应操作，包括是否需要录音、是否为长途区号、是否作为前缀号码及是否需要来电弹屏。显示在列表中的号码及对应信息可以通过点击界面右上角的添加号码信息 添加，见图 3‑22。

图 3‑22 添加号码信息界面

添加号码信息界面支持单个或批量添加号码信息。每个配置项的具体说明如下：

配置项 | 说明
电话号码 | 需要添加的电话号码，此栏不可以为空（不能为0）。
批量增加 | 用于批量增加电话号码，若不勾选，则增加数量 栏不可用。
增加数量 | 需要批量增加的电话号码数量，它以电话号码 栏中的号码为基础，以每次将电话号码 数值加1的方式进行增加（最多100个）。
需要录音 | 设置匹配到指定号码时，是否需要按照预先设定的录音触发方式进行录音，勾选则需要录音，否则一直不录音。
长途区号 | 勾选该选项时，匹配到对应号码的远端号码都被认为是长途号码，若远端号码与所有勾选长途区号的电话号码都没有匹配上，则被认为是市话。
前缀号码 | 表示对应号码是一串完整的电话号码，还是仅为一个电话号码的开头部分。若勾选，管理软件在检测到来电时仅验证来电号码的开头是否与此处设置的号码匹配；若不勾选，则来电号码需要与这个号码全部匹配且号码长度也一样，才被认为与设定号码匹配。若匹配则按照该号码设定的相关操作（如需要录音、长途区号、支持弹屏）进行处理。
支持弹屏 | 勾选该选项时，若来电号码与对应电话号码匹配，用户摘机后WEB端将弹出来电信息窗口（如图 3‑23所示），这个功能只有在3.2通道状态窗口有效，其它情况下都不会弹出来电提醒窗口。

图 3‑23 来电提醒窗口

说明：号码匹配的规则是按照号码长度优先的方式进行查找，即先按照整个来电号码进行匹配，若不匹配则去掉来电号码的最后一位，再与设置的号码进行匹配，依此类推。若匹配则直接按照该号码的设置进行处理。

配置完成后，点击保存 将以上设置存入数据库。需要重启才能使设置生效，可以通过 3.12重启复位菜单直接在WEB页面上重启录音服务。点击关闭 可直接取消设置。

点击图 3‑21中的修改 可以对号码信息进行修改。修改界面如图 3‑24所示，各配置项意义与添加号码信息 界面的配置项相同。

图 3‑24 电话号码修改界面

如果需要删除号码信息，可以在图 3‑21界面中选择对应号码前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录；反选 指取消选中当前页面已选中的记录，并选中原先未选中的记录。


3.4.4 IP配置

图 3‑25 IP配置界面

IP配置用于配置录音服务器的IP信息，使管理软件融入公司的局域网中。配置完成后点击保存。配置成功后，因IP改变，当前的WEB连接可能会出现问题，此时需要使用新配置的IP地址进行访问。点击重置 恢复当前配置。

注：图 3‑25中所示IP地址、子网掩码、默认网关和DNS服务器均为出厂时IP配置的默认值。


3.4.5 调试日志

图 3‑26 调试日志设置界面

见图 3‑26，调试日志设置界面主要用于配置录音服务的调试日志输出方式。调试日志可以方便对管理软件出现的问题进行调试跟踪。以上界面中各配置项说明如下图所示：

配置项

说明

日志等级

日志等级分成四级，分别为不输出日志、错误、警告、信息，等级级别依次提高，具体含义如下：

日志等级 | 含义说明
不输出日志 | 不产生日志文件。
错误 | 录音服务使用过程中的错误信息，信息体带|ERROR|字段，这种信息一般表示某次操作不成功或是错误的操作。
警告 | 录音服务使用过程中的警告信息，信息体带|WARNING|字段，这种信息一般表示某次操作可能会带来不良后果或操作结果不一定正确。
信息 | 录音服务使用过程中的一般信息，信息体带|INFO|字段，在普通功能函数调用过程或一般调试过程中，这种信息都会打印出来。

正常运行时建议将日志等级 设为“不输出日志”

创建日志周期

设置重新创建日志文件的时间间隔，单位为小时，最大周期为24小时，最小周期为1小时。

最大创建日志个数

设置最多可创建的日志文件数，若超过规定值，则不再产生日志文件，-1表示不存在该限制。

最大保留日志个数

设置最大可保留的日志文件数，若超过规定值，则最早生成的日志文件将会被最新的日志文件覆盖， -1表示不存在该限制。

是否覆盖原先的文件

表示录音服务被重启时，新产生的日志文件序号是否从0开始。选“是”，则从0开始，若已经存在相同序号的文件，则覆盖它；选“否”，则会重新生成一个与已经存在的日志序号不重复的文件进行日志记录。

保存路径

设置生成的日志文件的保存路径，它只规定日志文件的文件夹路径。日志文件名以如下格式自动生成，不可修改。

日志 | 文件名 | 举例
RecSvr | RecSvr日期_序号.log | RecSvr20120321_1.log
RecMonitor | RecMonitor日期_序号.log | RecMonitor20120321_1.log

配置完成后，点击保存 将以上设置存入数据库。需要重启才能使设置生效，可以通过 3.12重启复位 菜单直接在WEB页面上重启录音服务。点击重置 恢复当前配置。


3.4.6 告警设置

图 3‑27 告警设置界面

见图 3‑27，告警设置界面主要用于配置录音服务器的告警方式和告警间隔时间。以上界面中各配置项说明如下图所示：

配置项 | 说明
检测不到录音服务时自动重启 | 该功能开启时，录音监控模块（RecMonitor）在检测不到录音服务（RecSvr）时会自动重启录音服务，以保证录音服务在意外关闭的情况下能被重新启动。这样，管理软件即使出现故障也能重新进入录音状态。
告警功能 | 设置是否开启告警功能，包含：Web告警、蜂鸣器告警、邮件告警。
录音服务异常告警间隔 | 设置检测不到录音服务且一直未能恢复时，后一次告警与前一次告警之间的间隔时间。
线路异常告警间隔 | 设置话路通道断线且一直未能恢复时，后一次告警与前一次告警之间的间隔时间。
磁盘异常告警间隔 | 设置磁盘异常且一直未能恢复时，后一次告警与前一次告警之间的间隔时间。
集中管理设备断网告警间隔 | 设置集中管理子设备断网且一直未能恢复时，后一次告警与前一次告警之间的间隔时间。
是否开启无录音警告 | 该功能开启时，只要系统没有在规定的时间内进行录音就会产生告警信息，此时配置项白天多久没录音警告、白天时间段、晚上多久没录音警告 才有效。
白天时间段 | 设置被认为是白天的时间段，除白天时间段外的其余时间即被认为是晚上。
白天多久没录音需要警告 | 该配置项开启时，只要白天超过了设定时间没有录音就会产生告警信息。设定时间单位为分。可以在白天时间段 配置项中设置哪个时间段被认为是白天。
晚上多久没录音需要警告 | 该配置项开启时，只要晚上超过了设定时间没有录音就会产生告警信息。设定时间单位为分。可以在白天时间段 配置项中设置哪个时间段被认为是白天，除白天时间段外其余时间即被认为是晚上。
长时间无录音告警间隔 | 设置长时间无录音且一直未能恢复时，后一次告警与前一次告警之间的间隔时间。
告警时发送邮件通知 | 该功能开启时，系统产生告警信息后会发送告警邮件到指定的邮箱。告警信息见 3.15告警信息说明 。注意：该功能需要管理软件能访问指定的邮件服务器，否则无效。
邮件测试 | 向指定的邮箱发送一封测试邮件，确保邮件用户设置正确，能够收到告警邮件。
邮件用户 | 用于发送告警的邮件用户，建议申请专用的邮箱发送告警。
密码 | 发送告警的邮件用户对应的邮箱密码。因为密码是明文的，所以建议申请专用的邮箱发送告警，以防被其他拥有录音管理权限的用户知道该邮箱的密码而获取信息。
邮箱服务器 | 发送告警的邮箱对应的SMTP服务器，需要保证管理软件能访问该服务器，否则邮件无法成功发送。
邮件接收人 | 接收告警信息的邮件用户。如果有多个用户需要接收告警信息，则用“,”将邮箱用户隔开。
邮箱端口 | 设置邮箱服务器的端口，默认值为25。
SSL加密 | 设置是否启用SSL加密功能。


3.4.7 时间设置

图 3‑28 时间设置界面

见图 3‑28，时间设置可以采用手动修改或通过NTP服务器自动同步的方式实现。手动修改时需要勾选系统时间 中的复选框，然后在后面的编辑框内进行修改。NTP自动同步启用后，需要填写 NTP服务器的地址、同步周期 和时区。NTP默认为不启用。

修改完成后，点击设置 将以上设置存入数据库，时间设置只有在保存后才生效。点击重置 可恢复当前配置。

配置项 | 说明
系统时间 | 设置录音系统当前时间。
时区 | 设置当前时区。
时间自动同步 | 设置是否自动通过NTP同步系统时间。
同步服务器IP | 设置自动通过NTP同步系统时间的服务器IP地址。
同步周期 | 设置自动通过NTP同步系统时间的周期。


3.4.8 SNMP设置

图 3‑29 SNMP设置界面

见图 3‑29，SNMP设置界面主要用于配置SNMP参数，用户可以通过SNMP浏览器获取录音系统的信息。以上界面中各配置项说明如下图所示：

配置项 | 说明
SNMP配置 | 设置打开或者关闭SNMP服务。
SNMP服务器地址 | 设置允许使用SNMP协议获取录音系统信息的IP地址.
监听端口号 | 设置SNMP监听端口号，默认端口号为161，不建议修改。
只读共同体字符串 | 设置SNMP访问的只读共同体字符串，功能与密码相似。


3.4.9 远程更新

图 3‑30 远程更新界面

远程更新用于升级录音服务器的WEB界面、录音服务以及内核的版本。用户可以将我公司提供的更新包“ATP2400_xxxxxx.pack”放到本地PC上，通过请选择更新文件 选择，点击更新 即可升级。更新完毕后请重新登录系统。点击重置 可取消上传的更新文件，但不能用于取消更新。


3.4.10 WEB 设定

图 3‑31 WEB设置界面

WEB设定界面如图 3‑31所示，用户可以根据需要自主设定网页服务端口号。默认值为80.


3.5 用户管理

图 3‑32 用户管理界面

用户管理界面见图 3‑32，以上列表显示了拥有管理软件WEB访问权限的用户及对应的权限，只有具备用户管理权限的管理员才可以进入该界面，进行添加和删除用户、为每个用户指定不同的访问权限和查看初始密码等操作。操作权限包括添加系统设置、用户管理、信息管理、录音管理、通道设置、即时监听、文件删除、统计报表、日志查询、数据库管理、集中管理、集中查询和FTP管理。

注意：为了保护超级用户即admin，该界面不会显示admin用户的信息及其所有权限。

添加新用户可以点击以上界面右上角的添加管理员信息，见图 3‑33。

图 3‑33 添加管理员信息界面

各配置项说明如下：

配置项 | 说明
管理员名称 | 用户管理页面显示的管理员名称，也是该用户的登录名。
管理员密码 | 该用户访问WEB页面的登录密码。
确认密码 | 再次输入该用户访问WEB页面的登录密码。
系统设置 | 即3.4系统设置功能，只有拥有该权限的用户才能在系统设置栏中进行相关设置。
用户管理 | 即本章节的用户管理功能，只有拥有该权限的用户才能在菜单栏上看到此栏并进入该页面进行相关管理。注意：拥有此权限的用户可以在修改 界面看到其他用户的密码，因此高级管理员应谨慎添加具有该权限的用户。
信息管理 | 即3.6信息管理功能，只有拥有该权限的用户才可以在菜单栏上看到此栏并进入该页面进行信息查询和管理。
录音管理 | 即3.3.2录音参数功能，只有拥有该权限的用户才可以在菜单栏上看到此栏并进行录音参数的相关设置。
通道设置 | 控制3.2通道状态功能中修改通道属性的功能，只有拥有该权限的人才能进行通道属性的修改。
即时监听 | 拥有该权限的用户可以对正在录音的通道进行实时监听，详见3.14即时监听。
统计报表 | 即3.7统计报表功能，只有拥有该权限的用户才可以在菜单栏上看到这一栏并进行录音信息的统计。
日志查询 | 即3.8日志查询功能，只有拥有该权限的用户才可以进入日志查询界面，查询各个WEB用户对WEB的操作情况。
文件删除 | 拥有该权限的用户可以在录音查询结果界面（图 3‑8）对查询到的录音文件执行文件删除操作。
数据库管理 | 即3.10数据库管理功能，只有拥有该权限的用户才可以设置数据库是否自动备份、是否开启外部接口，才可以进行数据库还原操作。
集中管理 | 即3.11集中管理功能，只有拥有该权限的主设备用户才可以对网络中的从设备进行统一管理。
集中查询 | 拥有该权限的用户可以查看集中管理设备上的数据和信息。
FTP管理 | 用户可以通过其帐户密码登录FTP查看录音文件。 注：设置FTP权限之后需要重启系统。
通道选择 | 不同用户可查看的通道范围需要由管理员进行设置。当前用户只能查看自己权限范围内的通道和录音信息，弹屏也只弹出当前用户权限范围内的通道信息。

点击保存 将以上设置存入数据库，点击关闭 可直接取消设置。

点击图 3‑32中的修改 可以对用户信息进行修改。修改界面如图 3‑34所示，各配置项意义与添加管理员信息 界面的配置项相同。

图 3‑34 修改管理员信息界面

如果需要删除用户，可以在图 3‑32界面中选择对应号码前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录；反选 指取消选中当前页面已选中的记录，并选中原先未选中的记录。


3.6 信息管理

图 3‑35 信息管理栏

信息管理包括座席管理和客户管理两部分功能，详细介绍如下。


3.6.1 座席管理

图 3‑36 座席管理界面

座席管理界面见图 3‑36，以上列表显示了系统中所有座席人员的信息，包括工号、姓名、部门、职务和备注。用户可以在此界面上添加、修改、删除或导出这些信息。显示在列表中的座席信息可以通过点击界面右上角的添加座席信息 添加，见图 3‑37。

图 3‑37 添加座席信息界面

添加座席信息界面支持单个或批量添加座席人员信息，每个配置项的具体说明如下：

配置项 | 说明
批量添加 | 勾选此选项，从本地导入CSV表格到数据库中（注：通过另存为可将Excel表格保存为CSV表格）。目前一次性最多可以导入400条座席信息。表头格式如图 3‑38所示，只有按照该格式填写才能正常导入。批量添加时，如果导入的表格中的座席工号与存在的座席工号相同，则会直接覆盖当前的座席信息。
姓名、工号 | 座席人员姓名及工号，在添加座席人员信息时为必填项。工号可以为字符加数字的组合，但不能与之前存在的工号重复。
部门、职务、备注 | 座席人员的其它相关信息，在添加座席人员信息时为选填项

批量添加座席信息的Excel表头格式：

图 3‑38 座席信息Excel表头界面

配置完成后，点击确定 将以上设置存入数据库。添加的座席信息会显示在图 3‑36的列表中，点击关闭 可直接取消设置。

点击图 3‑36中的修改，可以修改座席信息。修改界面如图 3‑39所示，各配置项意义与添加座席信息 界面相同。

图 3‑39修改座席信息界面

为方便座席信息管理，用户还可以进行如下操作：

操作项 | 说明
导出座席信息 | 将数据库中所有座席人员的信息以CSV表格的形式导出到本地，方便对座席信息进行备份。
删除所选 | 删除选中的座席信息。全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录；反选 指取消选中当前页面已选中的记录，并选中原先未选中的记录。
清空座席 | 一键删除所有座席人员信息。


3.6.2 客户管理

图 3‑40 客户管理界面

客户管理界面见图 3‑40，以上列表显示了所有客户的基本信息，包括姓名、公司、部门、职务、电话、邮箱和备注等。用户在此界面上可以删除、添加、修改或导出这些信息。显示在列表中的客户信息可以通过点击界面右上角的添加客户信息 添加，见图 3‑41。

图 3‑41 添加客户信息界面

添加客户信息界面支持单个或批量添加客户信息，每个配置项的具体说明如下：

配置项 | 说明
批量添加 | 勾选此选项，从本地导入CSV表格到数据库中（注：通过另存为可将Excel表格保存为CSV表格）。目前一次性最多可以导入400条客户信息。表头格式如图 3‑42所示，只有按照该格式填写才能正常导入。批量添加时，如果导入的表格中的客户电话与存在的电话号码相同，则会直接覆盖当前的客户信息。
姓名 | 客户姓名，在添加客户信息时为必填项。
公司、部门、职务、地址、邮编、固定电话、手机号码、传真号码、Email、备注 | 客户的其它相关信息，在添加客户信息时为选填项。

批量添加客户信息的Excel表头格式：

图 3‑42 客户信息Excel表头界面

配置完成后，点击确定 将以上设置存入数据库。添加的客户信息会显示在图 3‑40的列表中，点击关闭 可直接取消设置。

点击图 3‑40中的修改，可以修改客户信息。修改界面如图 3‑43所示，各配置项意义与添加客户信息界面 相同。

图 3‑43 修改客户信息界面

为方便客户信息管理，用户还可以进行如下操作：

配置项 | 说明
导出客户信息 | 将数据库中所有客户的信息以CSV表格的形式导出到本地，方便对客户信息进行备份。
删除所选 | 删除选中的客户信息。全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录；反选 指取消选中当前页面已选中的记录，并选中原先未选中的记录。
清空客户 | 一键删除所有客户信息。


3.7 统计报表

图 3‑44 统计条件配置界面

统计报表支持通过多个条件组合查询并统计录音记录。见图 3‑44，以上界面显示了可进行配置的录音记录统计条件，具体说明如下：

配置项 | 说明
开始日期、开始时间、结束日期、结束时间 | 录音开始及结束的具体日期及时间段，比如上图中显示的查询时间段为2015-01-19 10:04:08到2015-01-20 14:09:50之间启动录音的录音数据。结束日期及时间应不早于开始日期及时间。
呼叫方向 | 以监控端作为参照，按照全部、呼入、呼出 三种方式进行过滤。
录音长度 | 一次通话的录音时间长度，可以按照不限、大于、小于 三种方式进行过滤。不限 指不对录音长度进行过滤；选择大于 或小于 时需要在后面的编辑框中输入参数（单位为秒），此时只有符合条件的录音才会被统计。
主叫号码、被叫号码 | 按照主叫号码、被叫号码进行过滤。如果需要对该项进行过滤，只要输入需要进行统计的号码即可。
座席工号、座席部门、座席姓名 | 输入座席相关信息（详见3.6.1座席管理），可根据输入内容进行过滤。
出局类型 | 区分市话及长途。提供全部、市话、长途 三个选项，选择全部 时不对出局类型进行过滤。
查询范围 | 指定统计报表查询录音数据的范围，提供最新 10万条记录、全部记录 两个选项，全部录音数据比较耗时，默认为最新 10万条记录。
未接来电 | 设置是否过滤未接来电，提供不限、是、否 三个选项，默认为不限。

查询条件配置完成后，点击统计 即可看到查询到的统计结果，查询结果如图 3‑45所示。点击重置 可恢复当前配置。

图 3‑45 各个通道统计结果

统计结果包括各个通道的统计结果及所有通道的统计结果总计，如图 3‑45所示。统计内容包括按录音次数计算的总次数、长话次数、市话次数、呼入次数、呼出次数、未接来电，单位为次；以及按录音时长计算的总时长、平均时长、长话时长、市话时长、呼入时长、呼出时长，单位为秒。


3.8 日志查询

图 3‑46 日志查询界面

日志查询界面显示了WEB用户所有的WEB操作情况及录音服务（RecSvr）、录音监控（RecMonitor）的起停情况，方便管理员全面地掌握管理软件的使用情况。日志信息按照操作时间进行逆序排列，即越新的操作在WEB页面上的显示越靠前。

点击日志查询界面右上角的导出查询结果 可以将查询的结果导出到Excel表格中，方便查看与保存。由于Excel 2003最大支持65535行，所以目前最多只能导出65535条查询结果，超过则会出现提示。


3.9 更改口令

图 3‑47 更改口令界面

更改口令需要输入原密码，然后输入并确认新密码，修改后点击保存 即可。在此界面中，所有用户都只能对自己的口令进行修改。若忘记原密码，可以要求超级管理员帮助查询。点击重置 可恢复当前配置。


3.10 数据库管理

数据库管理用于查询录音服务器的数据库状态，设置数据库自动备份功能以及数据库还原。数据库管理包括数据库设置和数据库还原两部分，如图 3‑48所示。

图 3‑48 数据库管理功能列表


3.10.1 数据库设置

图 3‑49 数据库设置界面

数据库设置界面如图 3‑49所示。数据库表单列表显示了录音服务器数据库表单的基本信息及状态，具体说明如下：

信息项 | 说明
表单名称 | 数据库中表单的名称，表单状态 为正常时，用户可以不关心此信息项。
表单状态 | 数据库中表单的状态，包括正常和异常。表单状态 为异常时，用户可以通过数据库还原功能将数据库还原到之前备份的正常状态。
备注 | 表单状态 的备注信息。表单状态 为异常时，备注栏会显示详细的表单异常信息。

用户可以在数据库设置界面进行以下配置：

配置项 | 说明
是否自动备份 | 设置录音服务器是否对数据库进行自动备份，以防止数据丢失。选择“是”后，是否备份到FTP服务器、自动备份间隔、备份路径 和备份保留天数 这四个配置项有效，否则无效。默认值为否。
是否备份到FTP服务器 | 设置自动备份数据库到FTP服务器。
自动备份间隔 | 设置录音服务器每隔多少时间自动备份数据库，单位为小时，默认值为24。
备份路径 | 录音服务器自动备份数据库的路径。
备份保留天数 | 设置数据库中信息备份的期限，超过该期限的数据表单将被自动删除，单位为天，默认为7。取值范围为1~10。
是否开启数据库外部接口 | 设置是否开放数据库用于二次开发，默认值为否。
外部接口帐号 | 通过外部接口访问数据库时使用的用户名。当配置项是否开启数据库外部接口 设置为是时，必须填写此配置项。
密码 | 通过外部接口访问数据库时使用的密码。当配置项是否开启数据库外部接口 设置为是时，必须填写此配置项。
允许使用外部接口的地址 | 能够访问数据库的外部接口的IP地址。如果设置多个IP地址，可以用“,”隔开。此配置项设置为“*”表示允许所有地址访问数据库。

配置完成后，点击保存 将以上信息存入数据库；点击重置 可恢复当前配置。


3.10.2 数据库还原

图 3‑50 数据库还原界面

数据库还原界面如图 3‑50所示，以上列表显示了数据库备份的时间点。用户需要还原数据库时，可以点击对应备份时间点前的选项框，然后点击还原。注意：还原数据库时只能选择一个时间点。点击重置 可以取消当前选择的备份时间点，但不能用于取消数据库还原操作。

如果需要删除备份，可以在图 3‑50界面中选择对应设备前的复选框，然后点击删除所选。全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录。


3.11 集中管理

图 3‑51 集中管理功能列表

集中管理将管理功能通过网络集中于一台主设备，管理者可以通过主设备实现对网络上所有从设备的统一管理。网络中只能够设置一台主设备，但从设备的数量不限。集中管理包括管理主页和主从设置两部分，如图 3‑51所示。管理主页显示了网络上所有接受集中管理的设备的基本信息，支持查询通道状态、录音记录、统计报表和操作日志以及修改设备参数；该界面仅对主设备用户开放。主从设置用于设置当前设备的主从关系和设备编号；该界面对主设备和从设备用户均开放。


3.11.1 管理主页

图 3‑52 管理主页界面

管理主页界面如图 3‑52所示，以上列表显示了网络中所有接受集中管理的设备。只有拥有集中管理权限的主设备用户才可以进入该界面查询、配置网络中从设备的信息。用户可以通过点击列表下方的添加设备 按钮添加新的从设备，如图 3‑53所示。

图 3‑53 添加设备界面

添加新设备时，填写IP地址，即可添加对应设备。用户也可以通过图 3‑52列表下方的搜索设备 按钮搜索并添加新的从设备。搜索设备时，只能自动搜索同网段的设备，例如主设备IP为192.168.1.5，只能搜索到IP在“192.168.1.1”到“192.168.1.255”之间的从设备，处于其他网段的从设备需要手动添加。界面如图 3‑54所示，界面右侧的数字表示搜索时间。

图 3‑54 搜索设备

设备搜索过程中，请耐心等待。搜索完毕后，会弹出对话框提示搜索完毕，搜索到的设备全部会出现在图 3‑52的集中管理设备列表中。

集中管理设备列表中各信息项或配置项的说明如下：

信息项/配置项

说明

设备编号

显示接受集中管理的设备的编号。

IP地址

显示接受集中管理的设备的IP地址。

通道数

显示接受集中管理的设备使用的通道数量。

工作状态

显示接受集中管理的设备当前的工作状态，包括：

工作状态 | 说明
设备断网 | 设备连接失败或未响应。
正常工作 | 设备运行正常。
数据库异常 | 设备数据库出现异常。
录音服务异常 | 录音服务程序异常。
硬盘异常 | 设备中没有插入硬盘，或者硬盘已满。
通道断线 | 设备中有断线的通道（设备需要开启通道没有正常工作告警）。
录音异常 | 白天或晚上长时间没有录音（设备需要开启长时间没有录音告警）。

当设备异常（即工作状态 不是正常工作）时，设备会根据设置通过告警音、WEB弹窗或邮件告警。将鼠标移至各设备的工作状态上方可以查看具体的状态信息。

通道详情

用户可以通过点击通道详情 链接查询接受集中管理的设备的通道状态，具体说明参见 3.2通道状态 。

录音查询

用户可以通过点击录音查询 链接查询接受集中管理的设备中的录音文件，具体说明参见 3.3.1录音查询 。

报表查询

用户可以通过点击报表查询 链接统计接受集中管理的设备中的录音信息，具体说明参见 3.7统计报表 。

日志查询

用户可以通过点击日志查询 链接查询接受集中管理的设备中的操作日志，具体说明参见 3.8日志查询 。

参数设置

用户可以通过点击参数设置 链接配置接受集中管理的设备，参数设置包括两部分：

分类 | 配置界面
系统设置 | 录音参数 、 系统配置 、 存储配置 、 号码设置 、 IP配置 、 调试日志 、 告警设置 、 时间设置 、 远程更新、 重新启动
信息管理 | 座席管理 、 客户管理 、 用户管理 、 更改口令

以上各配置界面的具体说明请点击链接，参考本手册中的对应章节。在录音参数、系统配置、存储配置、调试日志、时间设置界面保存修改的参数时，界面上会弹出同步设置提示框，如图 3‑55所示。用户可以根据需要将配置的参数同步到其它设备上。

同步设置界面如图 3‑55所示。如果用户需要将配置的参数同步到其它设备上，可以勾选对应设备前的复选框，然后点击确定。如果只将配置的参数保存到当前配置的设备上（默认已勾选），直接点击确定。点击取消 可以直接取消设置，不保存修改的参数。

注意：对于系统设置，同步设置只能同步当前路数的设置。如果接受同步的其它设备的通道数量大于当前设置的设备的通道数量，则多余通道的系统设置不会被同步。

图 3‑55 同步设置

如果需要删除接受集中管理的设备，可以在图 3‑52界面中选择对应设备前的复选框，然后点击删除所选。

如果需要一键重启集中管理的设备，可以在图 3‑52界面中选择对应设备前的复选框，然后点击重启服务 或重启系统 。重启服务 用于重启设备的录音服务（RecSvr），重启系统 用于重启录音服务器系统（System）。该功能在执行参数配置（包括同步设置）后尤为重要，涉及到参数更改（ 3.5用户管理 栏目除外）时，都需要重启服务 才能使新配置的参数生效。

全选 指选中当前页面可以选定的全部记录；全不选 指取消选中当前页面已经选定的全部记录。


3.11.2 主从设置

图 3‑56 主从设置界面

主从设置界面如图 3‑56所示，用于配置当前设备的工作模式和设备编号。拥有集中管理权限的主设备用户和从设备用户均可以进入此界面进行配置操作。以上各配置项具体说明如下：

配置项

说明

工作模式

设置当前录音服务器设备的工作模式，包括独立设备，主设备，从设备，从设备（PC），从设备（PC VPN）五种模式。从设备接受主设备管理，主设备接受管理者管理。

工作模式 | 说明
独立设备 | 作为独立的录音设备。
主设备 | 录音设备作为主机的集中管理模式的主设备。
从设备 | 录音设备作为主机的集中管理模式的从设备。
从设备（PC） | PC机作为主机的集中管理模式的从设备。
从设备（PC VPN） | PC机作为主机的集中管理模式的从设备（通过VPN连接）。

设备编号

当前录音服务器设备的设备编号。

设备IP

当前录音服务器的IP地址，此配置项不可以修改。

主机IP

当前录音服务器集中管理模式的主设备的IP地址。

配置完成后，点击保存 将以上信息存入数据库；点击重置 可恢复当前配置。


3.12 重启复位

重启复位功能支持用户通过WEB端重启服务、重启系统和清空记录，如图 3‑57所示。

图 3‑57 重启复位功能列表

重启服务用于重启录音服务器的录音服务（RecSvr）。该功能在执行参数配置后尤为重要，涉及到参数更改时，都需要重启录音服务才能使新配置的参数生效。

重启系统用于重启整个录音服务器系统（System）。

清空记录界面如图 3‑58所示。只有超级管理员用户才会在菜单中看到此功能。清空记录操作清除的数据包括录音文件、日志文件、备份文件，以及数据库中记录的座席信息、客户信息、号码信息、录音记录、用户信息和操作日志；未清除的数据则有录音参数、系统设置等。执行该操作时，用户需要输入登录密码并确认密码，然后点击确定。清空记录操作无法撤销，因此用户执行此操作需要谨慎。

图 3‑58 清空记录界面


3.13 FTP功能

为方便用户批量下载录音文件，录音服务器提供FTP功能。具体操作方法如下：在浏览器地址栏输入“ftp://服务器IP地址”登录FTP，然后输入用户名和密码。用户名为admin，密码为相应用户的密码；或者使用具有FTP管理权限用户的账户和密码登录。登录后可以看到对应盘符的文件夹，用户可以根据管理软件存储设置中配置的存储位置找到并下载对应的录音文件。

录音文件名的定义格式为：

yymmdd_hhmmssmmm_ch_userid_localnumber_remotenumber_calldirection.wav

以上各取值项的说明如下：

取值项 | 说明
yymmdd_hhmmssmmm | 录音开始时间，yymmdd为年月日，hhmmssmmm为时分秒毫秒。
ch | 录音通道的通道号，通道从1开始编号。
userid | 座席工号，可以为空。
localnumber | 本端号码。
remotenumber | 远端号码。
calldirection | 呼叫方向，0为呼入，1为呼出，-1为没有呼叫方向。

举例：

录音文件名：20140218_173229541_1_husidong_8236_8218_0.wav

其中，录音开始时间为2014-02-18 17:32:29.541，录音通道号为1，座席工号为husidong，本次呼叫的方向为呼入，本端号码为8236，远端号码为8218。在该文件名中，如果座席工号未知，则userid为空，此时文件名为：20140218_173229541_1_8236_8218_0.wav。

注意：录音文件名由管理软件自动生成，不可修改，否则录音文件将无法通过 3.3.1录音查询 功能查询到。


3.14 即时监听


3.14.1 安装RemoteListener

进入 3.2通道状态界面时，如果通道正在录音，会出现图 3‑59所示画面。在通道状态界面中有监听一列，可以选择对需要的通道进行监听。如图中通道2所示，监听列显示为 [image] 图标（监听 图标）的通道可以被监听。

图 3‑59 通道状态界面

若用户没有安装RemoteListener，点击监听 图标后会出现安全级别设置提示，如下图所示。请根据提示进入浏览器的工具-Internet选项-安全，进入自定义级别，将“没有标记为安全的ActiveX控件进行初始化和脚本运行”选为“启用”。

图 3‑60 提示安全级别设置

安全级别设置完成后，再次点击监听 图标，将出现下载安装监听插件的提示，如图 3‑61所示，选择确定，下载监听插件。

图 3‑61 提示下载监听插件

监听插件下载完成后得到如下图所示的文件。

图 3‑62 监听插件

双击RemoteListener.exe，安装监听工具。出现如下图所示对话框时，选择“是”。

图 3‑63 添加注册表


3.14.2 选择监听通道

安装成功后，在通道状态界面（图 3‑59）对需要监听的通道点击监听 图标（被监听的通道必须处于录音状态），在屏幕右下方出现蓝色系统托盘图标，如图 3‑64所示，表示监听工具已启动。

图 3‑64 监听工具系统托盘图标

对于正在监听的通道，其监听列的监听 图标“ [image] ”变为停止监听 图标“ [image] ”，点击停止监听 图标可以停止对当前通道的监听。正在监听的通道状态如下图通道1所示：

图 3‑65 正在监听的通道


3.14.3 监听工具的使用

图 3‑66 监听工具

监听工具在屏幕上显示为蓝色的系统托盘，右键点击后出现如图 3‑66所示的界面。用户可对监听工具进行如下操作：

操作项 | 说明
Device | 选择放音的设备。
Test | 对选择的设备进行放音测试。
Start | 开始监听。
Quit | 退出监听工具。

注意：即时监听的声音数据不一定会以录音文件的形式保存下来，因为录音结束后系统还需要对来去话录音限制、最短录音长度限制等进行过滤，只有符合条件的声音数据才会被保存。


3.15 告警信息说明


3.15.1 SD卡异常告警

告警内容 | 检测不到SD卡告警
告警信息 | 无
告警音 | 1长音（长音持续1000ms）
注意 | 由于SD卡是设备运行所必须的，因此在没有SD卡的情况下，设备将不断告警。


3.15.2 磁盘异常告警

告警内容 | 磁盘空间不足告警
告警信息 | 磁盘 %s 空间不足(%u<%u)！
告警音 | 2短音1长音（短音持续50ms，长音持续400ms，短音与短音之间、短音与长音之间间隔100ms）
举例 | 举例 磁盘 E 空间不足(600<800) 其中E为磁盘，600为当前实际的磁盘剩余空间，单位为MB，800为配置的最小剩余磁盘空间，单位为MB。
告警内容 | 检测不到磁盘告警
告警信息 | 录音系统检测不到磁盘！
告警音 | 2短音1长音（短音持续50ms，长音持续400ms，短音与短音之间、短音与长音之间间隔100ms）


3.15.3 长时间无录音告警

告警内容 | 夜晚长时间未录音
告警信息 | 晚上时间段长时间无录音！
告警音 | 2短音（短音持续50ms，短音与短音之间100ms）
告警内容 | 白天长时间未录音
告警信息 | 白天时间段长时间无录音！
告警音 | 2短音（短音持续50ms，短音与短音之间100ms）


3.15.4 线路异常告警

告警内容 | 线路通道断线
告警信息 | 线路断线，断线通道：a b c d 其中a、b、c、d代表没有正常工作的通道号。
告警音 | 4短音（短音持续50ms，短音与短音之间间隔100ms）


3.15.5 录音服务异常告警

告警内容 | 录音服务异常
告警信息 | 录音服务异常！
告警音 | 2长音（长音持续200ms，长音与长音之间间隔100ms）


3.15.6 集中管理设备断网告警

告警内容 | 集中管理子设备断网
告警信息 | 集中管理子设备 a(b) 断网！ 其中a代表设备IP，b代表设备编号。
告警音 | 1长音（长音持续100ms）


3.15.7 数据库损坏告警

告警内容 | 数据库损坏
告警信息 | 无
告警音 | 3长音（长音持续200ms，长音与长音之间间隔100ms）


附录A 主要技术/性能参数

外形尺寸：

长×高×深＝440×44×200 mm3

重 量：

2.7 kg（不包括硬盘及配件）

环境要求：

工作温度：0℃—40℃

储存温度：-20℃—85℃

湿 度：8%— 90% 无结露

储存湿度：8%— 90% 无结露

输入/输出接口：

电话线插座：8/16/24 个，RJ11，2芯

录音技术指标：

录音编码格式：

CCITT A/μ-Law 64kbps,

IMA ADPCM 32kbps

录音失真度：≤2％

频响：300-3400Hz(±3dB)

信噪比：≥38dB

系统最大容量：

最多24个通道。

电源要求：

+19V DC：1A

最大消耗功率：≤19W

阻抗：

录音输入：≥1MΩ/500V DC;

≥8kΩ/1000V AC

电话线对微机隔离绝缘电阻：

≥2MΩ/500V DC

电话线阻抗：符合国家标准三元件网络阻抗

音频编解码速率：

A-Law 64kbps

μ-Law 64kbps

ADPCM 32kbps

G.729A 8kbps

采样率：

8kHz

安全防护：

防雷击能力：4级


附录B 常见问题

1、 如何解决用IE10访问ATP2410不能在线播放或监听录音的问题？

目前Win7，Win8系统的IE10自带media player12播放器。导致不能播放录音的原因是media player高版本(12)与web兼容性不好，使用media player11及以下版本就不会出现此问题。用户也可以使用其它播放器，如realplayer。realplayer播放器下载地址： http://www.realplayer.cn/ 。

2、 ATP2410是否为标准的1U高度？能否不需要托板，直接固定到机柜上？

ATP2410采用标准1U高度，可以不需要托板直接固定在机柜上。

3、 使用ATP2410-24配置 500G 硬盘，大约可以存放多少天的录音文件？

以下数据以24个通道24小时不间断录音方式计算：

编码 | 可存放天数
A率 | 30
U率 | 30
ADPCM | 63
G.729A | 240


附录C 技术/销售支持

您在使用我们产品的过程中，有任何疑问都可以与我们联系，我们将尽心尽力提供服务。

公司联系方法：

杭州三汇信息工程有限公司

http：//www.synway.cn

地址：杭州滨江区南环路3756号三汇研发大楼 9F

邮编：310053

电话：0571-88861158（总机）

传真：0571-88850923

微信二维码：请扫描下图二维码添加公司微信订阅号了解更多详情。

技术支持：

电话：0571-88921532（工作日8:30 - 17:00）

手机：（0）13306501675（24小时热线）

Email：support@sanhuid.com

销售部：

电话：0571-86695356

Email：13989830066@139.com